re = /(?<=\d)_(?=\d+-)/m
str = 'scaffold_97606_2-BACs_-__SP1_1
UELV01165908.1_2-BACs_+__SP2_2
UXGC01046554.1_9-702_+__SP3_3
scaffold_12002_1087-1579_-__SP4_4
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end