const regex = /(?<![^,])(?:rss-latest|listing-latest-no-category|category-128|page-9000)(?![^,])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<![^,])(?:rss-latest|listing-latest-no-category|category-128|page-9000)(?![^,])', 'gm')
const str = `page-9000,page-template,page-type,page-category-128,image-195,listing-latest,rss-latest,even-more-info,even-more-tags`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}