re = /(?<![^,])(?:rss-latest|listing-latest-no-category|category-128|page-9000)(?![^,])/m
str = 'page-9000,page-template,page-type,page-category-128,image-195,listing-latest,rss-latest,even-more-info,even-more-tags'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end