using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @", (\w+\.)";
string input = @"Braund, Mr. Owen Harris
Cumings, Mrs. John Bradley (Florence Briggs)
Heikkinen, Miss. Laina
Futrelle, Mrs. Jacques Heath (Lily May Peel)
Allen, Mr. William Henry";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}