import re
regex = re.compile(r", (\w+\.)", flags=re.MULTILINE)
test_str = ("Braund, Mr. Owen Harris\n"
"Cumings, Mrs. John Bradley (Florence Briggs)\n"
"Heikkinen, Miss. Laina\n"
"Futrelle, Mrs. Jacques Heath (Lily May Peel)\n"
"Allen, Mr. William Henry")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")