use strict;
my $str = '2015-05-13T23:39:43.945958Z my-loadbalancer 192.168.131.39:2817 10.0.0.1:80 0.000086 0.001048 0.001337 200 200 0 57 "GET https://www.example.com:443/ HTTP/1.1" "curl/7.38.0" DHE-RSA-AES128-SHA TLSv1.2
2015-05-13T23:39:43.945958Z my-loadbalancer 192.168.131.39:2817 10.0.0.1:80 0.001069 0.000028 0.000041 - - 82 305 "- - - " "-" - -
2015-05-13T23:39:43.945958Z my-loadbalancer 192.168.131.39:2817 10.0.0.1:80 0.001065 0.000015 0.000023 - - 57 502 "- - - " "-" ECDHE-ECDSA-AES128-GCM-SHA256 TLSv1.2';
my $regex = qr/^(?P<timestamp>[^\s]+)\s*(?P<elb>[^\s]+)\s*(?P<client_addr>[^:]+):\s*(?P<client_port>[^\s]+)\s*(?P<target_addr>[^:]+):\s*(?P<target_port>[^\s]+)\s*(?P<request_processing_time>[^\s]+)\s*(?P<backend_processing_time>[^\s]+)\s*(?P<response_processing_time>[^\s]+)\s*(?P<elb_status_code>[^\s]+)\s*(?P<backend_status_code>[^\s]+)\s*(?P<received_bytes>[^\s]+)\s*(?P<sent_bytes>[^\s]+)\s*"(?P<request>[^\"]+)"\s*(?P<user_agent>[^\s]+)\s*(?P<ssl_cipher>[^\s]+)\s*(?P<ssl_protocol>[^\s]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}