# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?P<timestamp>[^\s]+)\s*(?P<elb>[^\s]+)\s*(?P<client_addr>[^:]+):\s*(?P<client_port>[^\s]+)\s*(?P<target_addr>[^:]+):\s*(?P<target_port>[^\s]+)\s*(?P<request_processing_time>[^\s]+)\s*(?P<backend_processing_time>[^\s]+)\s*(?P<response_processing_time>[^\s]+)\s*(?P<elb_status_code>[^\s]+)\s*(?P<backend_status_code>[^\s]+)\s*(?P<received_bytes>[^\s]+)\s*(?P<sent_bytes>[^\s]+)\s*\"(?P<request>[^\"]+)\"\s*(?P<user_agent>[^\s]+)\s*(?P<ssl_cipher>[^\s]+)\s*(?P<ssl_protocol>[^\s]+)"
test_str = ("2015-05-13T23:39:43.945958Z my-loadbalancer 192.168.131.39:2817 10.0.0.1:80 0.000086 0.001048 0.001337 200 200 0 57 \"GET https://www.example.com:443/ HTTP/1.1\" \"curl/7.38.0\" DHE-RSA-AES128-SHA TLSv1.2\n\n"
"2015-05-13T23:39:43.945958Z my-loadbalancer 192.168.131.39:2817 10.0.0.1:80 0.001069 0.000028 0.000041 - - 82 305 \"- - - \" \"-\" - -\n\n"
"2015-05-13T23:39:43.945958Z my-loadbalancer 192.168.131.39:2817 10.0.0.1:80 0.001065 0.000015 0.000023 - - 57 502 \"- - - \" \"-\" ECDHE-ECDSA-AES128-GCM-SHA256 TLSv1.2")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.