#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)cdn.discordapp.com\/attachments\/[\d\w\/]+.(png|jpg|gif)"
Local $sString = "imgur.com/ghOCjsn" & @CRLF & _
"imgur.com/a/Tkyl6" & @CRLF & _
"i.imgur.com/ghOCjsn.png" & @CRLF & _
"i.imgur.com\/[\d\w]+.(png|jpg|gif)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"https://cdn.discordapp.com/attachments/738526872186650694/759759076715528253/image0.jpg" & @CRLF & _
"https://cdn.discordapp.com/attachments/650589304308891648/761662319209349140/ww.png" & @CRLF & _
"https://cdn.discordapp.com/attachments/764157854512316496/764160227506782228/E.docx"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")