import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\d)(?:(?:(?:1[6-9]|[2-9]\\d)?\\d{2})(?:(?:(?:0[13578]|1[02])31)|(?:(?:0[1,3-9]|1[0-2])(?:29|30)))|(?:(?:(?:(?:1[6-9]|[2-9]\\d)?(?:0[48]|[2468][048]|[13579][26])|(?:(?:16|[2468][048]|[3579][26])00)))0229)|(?:(?:1[6-9]|[2-9]\\d)?\\d{2})(?:(?:0?[1-9])|(?:1[0-2]))(?:0?[1-9]|1\\d|2[0-8]))(?!\\d)";
final String string = "aaa_20150229_bbb\n"
+ "aaa_20120229_bbb\n"
+ "aaa_20000229_bbb\n"
+ "aaa_19000229_bbb\n"
+ "aaa_18000229_bbb\n"
+ "aaa_17000229_bbb\n"
+ "aaa_16000229_bbb\n\n"
+ "aaa_20150130_bbb\n"
+ "aaa_20150131_bbb\n"
+ "aaa_20150430_bbb\n"
+ "aaa_20150431_bbb";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}