re = /(?<!\d)(?:(?:(?:1[6-9]|[2-9]\d)?\d{2})(?:(?:(?:0[13578]|1[02])31)|(?:(?:0[1,3-9]|1[0-2])(?:29|30)))|(?:(?:(?:(?:1[6-9]|[2-9]\d)?(?:0[48]|[2468][048]|[13579][26])|(?:(?:16|[2468][048]|[3579][26])00)))0229)|(?:(?:1[6-9]|[2-9]\d)?\d{2})(?:(?:0?[1-9])|(?:1[0-2]))(?:0?[1-9]|1\d|2[0-8]))(?!\d)/m
str = 'aaa_20150229_bbb
aaa_20120229_bbb
aaa_20000229_bbb
aaa_19000229_bbb
aaa_18000229_bbb
aaa_17000229_bbb
aaa_16000229_bbb
aaa_20150130_bbb
aaa_20150131_bbb
aaa_20150430_bbb
aaa_20150431_bbb'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end