using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\bcontent:\s*([^;""']*(?:""[^""]*""[^;""']*|'[^']*'[^;""']*)*)";
string input = @"content: counter(item)"" "" attr(data) "" counter(item1,decimal) url('test.jpeg') ""hi"" attr(xyz); color:red;
content: "" data = "" attr(data) "", image = "" url('test.jpeg');";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}