$re = '/.*\bcontent:\s*([^;"\']*(?:"[^"]*"[^;"\']*|\'[^\']*\'[^;"\']*)*)/m';
$str = 'content: counter(item)" " attr(data) "" counter(item1,decimal) url(\'test.jpeg\') "hi" attr(xyz); color:red;
content: " data = " attr(data) ", image = " url(\'test.jpeg\');';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);