re = /^((?!(<\S)|(\S>)).)*$/m
str = ' uygt uygqsdf < uhkuki ukh > q< sd > < < < > > < < > qssdf qqsfd dsfghd < >W > > q >sd< '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end