using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)<!--.*?-->(*SKIP)(*F)|(?:(?!<!--).)+";
string input = @"<!-- abc --><bar> foo<!-- de --></bar> baz";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}