$re = '/(?s)<!--.*?-->(*SKIP)(*F)|(?:(?!<!--).)+/';
$str = '<!-- abc --><bar> foo<!-- de --></bar> baz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);