using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"cancelLink: '(.*?)'";
string input = @"environment = {
prop1: value,
prop2: env.prop,
propArray: ['','',''],
prop: host + 'somestring',
cancelLink: 'myvaluetocatch'
};";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}