$re = '/cancelLink: \'(.*?)\'/m';
$str = 'environment = {
prop1: value,
prop2: env.prop,
propArray: [\'\',\'\',\'\'],
prop: host + \'somestring\',
cancelLink: \'myvaluetocatch\'
};';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);