re = /\((-?\d+)\|(-?\d+)\)/
str = '(-112|-522)
(-112|522)
(112|-522)
(112|522)
(-112|-522)
(-112|522)
(112|-522)
(112|522)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end