// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\((-?\d+)\|(-?\d+)\)").unwrap();
let string = "(-112|-522)
(-112|522)
(112|-522)
(112|522)
(-112|-522)
(-112|522)
(112|-522)
(112|522)
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}