#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^function\(.*\)"
Local $sString = "alert(__t('Mingi tekst') ); " & @CRLF & _
"alert(__t("Mingi tekst") );" & @CRLF & _
"alert(__t( var_name ) );" & @CRLF & _
"__t('Mingi tekst') " & @CRLF & _
"function name() {" & @CRLF & _
" console.log(__t('sdfsdf'));" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")