const regex = /^function\(.*\)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^function\\(.*\\)', '')
const str = `alert(__t('Mingi tekst') );
alert(__t("Mingi tekst") );
alert(__t( var_name ) );
__t('Mingi tekst')
function name() {
console.log(__t('sdfsdf'));
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}