// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\.[\w.]+|[\w.]+\.)$").unwrap();
let string = "brew.pixels
brew.pixels
dfg21.dfgd
brew.pixels.
.brew.pixels";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}