package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^a-z\d-]`)
var str = ` testando um nome de flag-uhuu-com-acento-ão_2 @!´\`~]][[[
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}