use strict;
my $str = ' testando um nome de flag-uhuu-com-acento-ão_2 @!´`~]][[[
';
my $regex = qr`[^a-z\d-]`mp;
my $subst = '';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";