#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?<!\d|\-|\+|\.)(?P<ch_a>[\u4e00-\u9fff]{2})?(?P<Hours>[0-2]?\d)(?:[:\.时時]| ?h ?)(?P<Minutes>[0-5]\d(?!\d))\:?(?:(?:[:\.分]| ?m ?)(?P<Seconds>[0-5]\d(?!\d)))?秒?(?:[,\.](?P<SecodsFraction>\d{9}|\d{6}|\d{3}(?!\d)))?(?:\ \w\W)?(?:[\.\s]?(?:(?P<Z>(?:[a-zA-Z]{3,5}|Z|\[\w+\/\w+\])|(?:[+-]\d\d?\:?[0,3,4]?[0,5]?))|(?P<a>[dapmDAPM]{2})))*(?!\S))"
Local $sString = "19990322+0100" & @CRLF & _
"19990322" & @CRLF & _
"1999-03-22 AD" & @CRLF & _
"1999-03-22+01:00" & @CRLF & _
"1999-03-22T05:06:07.000[Europe/Paris]" & @CRLF & _
"1999-03-22T05:06:07.000" & @CRLF & _
"1999-03-22T05:06:07" & @CRLF & _
"1999-03-22T05:06:07.000Z" & @CRLF & _
"1999-03-22T05:06:07.000+01:00" & @CRLF & _
"1999-03-22T05:06:07+01:00" & @CRLF & _
"1999-081+01:00" & @CRLF & _
"1999W132" & @CRLF & _
"1999-W13-2" & @CRLF & _
"1999-03-22T05:06:07.000+01:00[Europe/Paris]" & @CRLF & _
"1999-03-22T05:06:07+01:00[Europe/Paris]" & @CRLF & _
"22.3.99" & @CRLF & _
"22.3.99 5.06" & @CRLF & _
"22.3.1999 5.06.07" & @CRLF & _
"22.3.1999 5:06:07" & @CRLF & _
"22-03-99" & @CRLF & _
"22-03-99 05:06" & @CRLF & _
"22-03-1999 05:06:07" & @CRLF & _
"22.03.99" & @CRLF & _
"22. März 1999" & @CRLF & _
"Montag, 22. März 1999" & @CRLF & _
"22.03.1999" & @CRLF & _
"22.03.99 05:06" & @CRLF & _
"22. März 1999 05:06:07 MEZ" & @CRLF & _
"22.03.1999 05:06:07" & @CRLF & _
"22.03.99 05:06:07" & @CRLF & _
"22.03.1999 05:06" & @CRLF & _
"Montag, 22. März 1999 05:06 Uhr MEZ" & @CRLF & _
"22-Mar-1999" & @CRLF & _
"22/03/99 5:06 AM" & @CRLF & _
"Monday, March 22, 1999 5:06:07 o'clock AM CET" & @CRLF & _
"22-Mar-1999 5:06:07 AM" & @CRLF & _
"22 March 1999" & @CRLF & _
"Monday, 22 March 1999" & @CRLF & _
"22-Mar-1999" & @CRLF & _
"22 March 1999 05:06:07 CET" & @CRLF & _
"Monday, 22 March 1999 05:06:07 o'clock CET" & @CRLF & _
"22-Mar-1999 05:06:07" & @CRLF & _
"22-Mar-99 05.06.07.000000888 AM" & @CRLF & _
"3/22/99" & @CRLF & _
"03/11/22" & @CRLF & _
"03-22-99" & @CRLF & _
"3-22-99" & @CRLF & _
"Mar 22, 1999" & @CRLF & _
"March 22, 1999" & @CRLF & _
"Monday, March 22, 1999" & @CRLF & _
"Mar 22 1999" & @CRLF & _
"March 22 1999" & @CRLF & _
"03-22-1999" & @CRLF & _
"3-22-1999" & @CRLF & _
"1999-03-22+01:00" & @CRLF & _
"22/03/1999" & @CRLF & _
"22/3/1999" & @CRLF & _
"03/22/1999" & @CRLF & _
"3/22/1999" & @CRLF & _
"1999/3/22" & @CRLF & _
"3/22/99 5:06 AM" & @CRLF & _
"03/22/99 5:06 AM" & @CRLF & _
"03-22-99 5:06 AM" & @CRLF & _
"3-22-99 5:06 AM" & @CRLF & _
"Mar 22, 1999 5:06:07 AM" & @CRLF & _
"Monday, March 22, 1999 5:06:07 AM CET" & @CRLF & _
"Mon Mar 22 05:06:07 CET 1999" & @CRLF & _
"Mon, 22 Mar 1999 05:06:07 +0100" & @CRLF & _
"22 Mar 1999 05:06:07 +0100" & @CRLF & _
"03-22-1999 5:06:07 AM" & @CRLF & _
"3-22-1999 5:06:07 AM" & @CRLF & _
"1999-03-22 5:06:07 AM" & @CRLF & _
"1999-3-22 5:06:07 AM" & @CRLF & _
"1999-03-22 05:06:07.0" & @CRLF & _
"22/03/1999 5:06:07 AM" & @CRLF & _
"22/3/1999 5:06:07 AM" & @CRLF & _
"03/22/1999 5:06:07 AM" & @CRLF & _
"3/22/1999 5:06:07 AM" & @CRLF & _
"03/22/99 5:06:07 AM" & @CRLF & _
"03/22/99 5:06:07" & @CRLF & _
"3/22/99 5:06:07" & @CRLF & _
"22/03/1999 5:06 AM" & @CRLF & _
"22/3/1999 5:06 AM" & @CRLF & _
"03/22/1999 5:06 AM" & @CRLF & _
"3/22/1999 5:06 AM" & @CRLF & _
"03-22-99 5:06:07 AM" & @CRLF & _
"3-22-99 5:06:07 AM" & @CRLF & _
"03-22-1999 5:06 AM" & @CRLF & _
"3-22-1999 5:06 AM" & @CRLF & _
"1999-03-22 5:06 AM" & @CRLF & _
"1999-3-22 5:06 AM" & @CRLF & _
"Mar.22.1999" & @CRLF & _
"22/Mar/1999 5:06:07 +0100" & @CRLF & _
"22/Mar/99 5:06 AM" & @CRLF & _
"22/03/99" & @CRLF & _
"22/03/99 5:06" & @CRLF & _
"22.3.99 5:06" & @CRLF & _
"22.03.99" & @CRLF & _
"22.03.1999" & @CRLF & _
"22.03.99 5:06" & @CRLF & _
"22.03.1999 5:06:07" & @CRLF & _
"22.3.1999" & @CRLF & _
"22.3.1999 5:06" & @CRLF & _
"99-03-22" & @CRLF & _
"1999-03-22" & @CRLF & _
"22 mars 1999 05:06:07 CET" & @CRLF & _
"March 22, 1999 5:06:07 CET AM" & @CRLF & _
"1999-03-22 05:06:07" & @CRLF & _
"lundi 22 mars 1999 5 h 06 CET" & @CRLF & _
"22/03/99" & @CRLF & _
"22 mars 1999" & @CRLF & _
"22 mars 1999" & @CRLF & _
"lundi 22 mars 1999" & @CRLF & _
"22/03/99 05:06" & @CRLF & _
"03/22/99 05:06" & @CRLF & _
"3/22/99 05:06" & @CRLF & _
"03-22-99 05:06" & @CRLF & _
"3-22-99 05:06" & @CRLF & _
"22 mars 1999 05:06:07" & @CRLF & _
"22 mars 1999 05:06:07 CET" & @CRLF & _
"03-22-1999 05:06:07" & @CRLF & _
"3-22-1999 05:06:07" & @CRLF & _
"1999-3-22 05:06:07" & @CRLF & _
"22/03/1999 05:06:07" & @CRLF & _
"22/3/1999 05:06:07" & @CRLF & _
"03/22/1999 05:06:07" & @CRLF & _
"3/22/1999 05:06:07" & @CRLF & _
"lundi 22 mars 1999 05 h 06 CET" & @CRLF & _
"22/03/99 05:06:07" & @CRLF & _
"03/22/99 05:06:07" & @CRLF & _
"3/22/99 05:06:07" & @CRLF & _
"22/03/1999 05:06" & @CRLF & _
"22/3/1999 05:06" & @CRLF & _
"03/22/1999 05:06" & @CRLF & _
"3/22/1999 05:06" & @CRLF & _
"03-22-99 05:06:07" & @CRLF & _
"3-22-99 05:06:07" & @CRLF & _
"03-22-1999 05:06" & @CRLF & _
"3-22-1999 05:06" & @CRLF & _
"1999-3-22 05:06" & @CRLF & _
"99/03/22 05:06" & @CRLF & _
"1999.03.22" & @CRLF & _
"1999.03.22 05:06:07" & @CRLF & _
"1999.03.22 05:06" & @CRLF & _
"1999.03.22." & @CRLF & _
"1999.03.22. 5:06:07" & @CRLF & _
"1999.03.22. 5:06" & @CRLF & _
"22.3.1999 05:06:07" & @CRLF & _
"22.3.1999 05:06" & @CRLF & _
"22-mar-1999" & @CRLF & _
"22/03/99 5.06" & @CRLF & _
"99-03-22 05:06" & @CRLF & _
"22-mar-1999 5.06.07" & @CRLF & _
"22 marzo 1999 5.06.07 CET" & @CRLF & _
"lunedì 22 marzo 1999 5.06.07 CET" & @CRLF & _
"05:06 22/03/99" & @CRLF & _
"05:06:07 22/03/1999" & @CRLF & _
"99/03/22" & @CRLF & _
"1999/03/22" & @CRLF & _
"99/03/22 5:06" & @CRLF & _
"03/22/99 5:06" & @CRLF & _
"3/22/99 5:06" & @CRLF & _
"03-22-99 5:06" & @CRLF & _
"3-22-99 5:06 AM" & @CRLF & _
"03-22-1999 5:06:07" & @CRLF & _
"3-22-1999 5:06:07" & @CRLF & _
"1999-03-22 5:06:07" & @CRLF & _
"99/03/22 5:06:07" & @CRLF & _
"3/22/99 5:06:07 AM" & @CRLF & _
"1999/03/22 5:06" & @CRLF & _
"22/03/1999 5:06" & @CRLF & _
"22/3/1999 5:06" & @CRLF & _
"03/22/1999 5:06" & @CRLF & _
"3/22/1999 5:06" & @CRLF & _
"03-22-99 5:06:07" & @CRLF & _
"3-22-99 5:06:07" & @CRLF & _
"03-22-1999 5:06" & @CRLF & _
"3-22-1999 5:06" & @CRLF & _
"1999-03-22 5:06" & @CRLF & _
"1999-3-22 5:06" & @CRLF & _
"99. 3. 22" & @CRLF & _
"1999. 3. 22" & @CRLF & _
"99.3.22" & @CRLF & _
"99.3.22 05.06" & @CRLF & _
"1999-03-22 05.06.07" & @CRLF & _
"99.22.3" & @CRLF & _
"1999.22.3" & @CRLF & _
"99.22.3 05:06" & @CRLF & _
"1999.22.3 05:06:07" & @CRLF & _
"22.3.99 05:06" & @CRLF & _
"22.3.1999 05:06:" & @CRLF & _
"22-3-99" & @CRLF & _
"22-3-99 5:06" & @CRLF & _
"22-03-1999" & @CRLF & _
"22-03-1999 5:06" & @CRLF & _
"22.03.99 5:06" & @CRLF & _
"22.03.1999 5:06:07" & @CRLF & _
"1999-03-22 5:06:07.PD" & @CRLF & _
"99-03-22 5.06.PD" & @CRLF & _
"1999-03-22 5.06.07.PD CET" & @CRLF & _
"22.3.99." & @CRLF & _
"22.03.1999." & @CRLF & _
"22.3.99. 05.06" & @CRLF & _
"22.03.1999. 05.06.07" & @CRLF & _
"22.03.1999. 05.06.07 CET" & @CRLF & _
"05:06:07 22-03-1999" & @CRLF & _
"05:06 22/03/1999" & @CRLF & _
"99-3-22" & @CRLF & _
"1999-3-22" & @CRLF & _
"1999年3月22日" & @CRLF & _
"1999年3月22日 星期一" & @CRLF & _
"99-3-22 上午5:06" & @CRLF & _
"1999-3-22 5:06:07" & @CRLF & _
"1999年3月22日 上午05时06分07秒" & @CRLF & _
"1999年3月22日 5時06分07秒 CET" & @CRLF & _
"1999年3月22日 星期一 上午05时06分07秒 CET" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")