import re
regex = re.compile(r"(?:(?<!\d|\-|\+|\.)(?P<ch_a>[\u4e00-\u9fff]{2})?(?P<Hours>[0-2]?\d)(?:[:\.时時]| ?h ?)(?P<Minutes>[0-5]\d(?!\d))\:?(?:(?:[:\.分]| ?m ?)(?P<Seconds>[0-5]\d(?!\d)))?秒?(?:[,\.](?P<SecodsFraction>\d{9}|\d{6}|\d{3}(?!\d)))?(?:\ \w\W)?(?:[\.\s]?(?:(?P<Z>(?:[a-zA-Z]{3,5}|Z|\[\w+\/\w+\])|(?:[+-]\d\d?\:?[0,3,4]?[0,5]?))|(?P<a>[dapmDAPM]{2})))*(?!\S))", flags=re.MULTILINE)
test_str = ("19990322+0100\n"
"19990322\n"
"1999-03-22 AD\n"
"1999-03-22+01:00\n"
"1999-03-22T05:06:07.000[Europe/Paris]\n"
"1999-03-22T05:06:07.000\n"
"1999-03-22T05:06:07\n"
"1999-03-22T05:06:07.000Z\n"
"1999-03-22T05:06:07.000+01:00\n"
"1999-03-22T05:06:07+01:00\n"
"1999-081+01:00\n"
"1999W132\n"
"1999-W13-2\n"
"1999-03-22T05:06:07.000+01:00[Europe/Paris]\n"
"1999-03-22T05:06:07+01:00[Europe/Paris]\n"
"22.3.99\n"
"22.3.99 5.06\n"
"22.3.1999 5.06.07\n"
"22.3.1999 5:06:07\n"
"22-03-99\n"
"22-03-99 05:06\n"
"22-03-1999 05:06:07\n"
"22.03.99\n"
"22. März 1999\n"
"Montag, 22. März 1999\n"
"22.03.1999\n"
"22.03.99 05:06\n"
"22. März 1999 05:06:07 MEZ\n"
"22.03.1999 05:06:07\n"
"22.03.99 05:06:07\n"
"22.03.1999 05:06\n"
"Montag, 22. März 1999 05:06 Uhr MEZ\n"
"22-Mar-1999\n"
"22/03/99 5:06 AM\n"
"Monday, March 22, 1999 5:06:07 o'clock AM CET\n"
"22-Mar-1999 5:06:07 AM\n"
"22 March 1999\n"
"Monday, 22 March 1999\n"
"22-Mar-1999\n"
"22 March 1999 05:06:07 CET\n"
"Monday, 22 March 1999 05:06:07 o'clock CET\n"
"22-Mar-1999 05:06:07\n"
"22-Mar-99 05.06.07.000000888 AM\n"
"3/22/99\n"
"03/11/22\n"
"03-22-99\n"
"3-22-99\n"
"Mar 22, 1999\n"
"March 22, 1999\n"
"Monday, March 22, 1999\n"
"Mar 22 1999\n"
"March 22 1999\n"
"03-22-1999\n"
"3-22-1999\n"
"1999-03-22+01:00\n"
"22/03/1999\n"
"22/3/1999\n"
"03/22/1999\n"
"3/22/1999\n"
"1999/3/22\n"
"3/22/99 5:06 AM\n"
"03/22/99 5:06 AM\n"
"03-22-99 5:06 AM\n"
"3-22-99 5:06 AM\n"
"Mar 22, 1999 5:06:07 AM\n"
"Monday, March 22, 1999 5:06:07 AM CET\n"
"Mon Mar 22 05:06:07 CET 1999\n"
"Mon, 22 Mar 1999 05:06:07 +0100\n"
"22 Mar 1999 05:06:07 +0100\n"
"03-22-1999 5:06:07 AM\n"
"3-22-1999 5:06:07 AM\n"
"1999-03-22 5:06:07 AM\n"
"1999-3-22 5:06:07 AM\n"
"1999-03-22 05:06:07.0\n"
"22/03/1999 5:06:07 AM\n"
"22/3/1999 5:06:07 AM\n"
"03/22/1999 5:06:07 AM\n"
"3/22/1999 5:06:07 AM\n"
"03/22/99 5:06:07 AM\n"
"03/22/99 5:06:07\n"
"3/22/99 5:06:07\n"
"22/03/1999 5:06 AM\n"
"22/3/1999 5:06 AM\n"
"03/22/1999 5:06 AM\n"
"3/22/1999 5:06 AM\n"
"03-22-99 5:06:07 AM\n"
"3-22-99 5:06:07 AM\n"
"03-22-1999 5:06 AM\n"
"3-22-1999 5:06 AM\n"
"1999-03-22 5:06 AM\n"
"1999-3-22 5:06 AM\n"
"Mar.22.1999\n"
"22/Mar/1999 5:06:07 +0100\n"
"22/Mar/99 5:06 AM\n"
"22/03/99\n"
"22/03/99 5:06\n"
"22.3.99 5:06\n"
"22.03.99\n"
"22.03.1999\n"
"22.03.99 5:06\n"
"22.03.1999 5:06:07\n"
"22.3.1999\n"
"22.3.1999 5:06\n"
"99-03-22\n"
"1999-03-22\n"
"22 mars 1999 05:06:07 CET\n"
"March 22, 1999 5:06:07 CET AM\n"
"1999-03-22 05:06:07\n"
"lundi 22 mars 1999 5 h 06 CET\n"
"22/03/99\n"
"22 mars 1999\n"
"22 mars 1999\n"
"lundi 22 mars 1999\n"
"22/03/99 05:06\n"
"03/22/99 05:06\n"
"3/22/99 05:06\n"
"03-22-99 05:06\n"
"3-22-99 05:06\n"
"22 mars 1999 05:06:07\n"
"22 mars 1999 05:06:07 CET\n"
"03-22-1999 05:06:07\n"
"3-22-1999 05:06:07\n"
"1999-3-22 05:06:07\n"
"22/03/1999 05:06:07\n"
"22/3/1999 05:06:07\n"
"03/22/1999 05:06:07\n"
"3/22/1999 05:06:07\n"
"lundi 22 mars 1999 05 h 06 CET\n"
"22/03/99 05:06:07\n"
"03/22/99 05:06:07\n"
"3/22/99 05:06:07\n"
"22/03/1999 05:06\n"
"22/3/1999 05:06\n"
"03/22/1999 05:06\n"
"3/22/1999 05:06\n"
"03-22-99 05:06:07\n"
"3-22-99 05:06:07\n"
"03-22-1999 05:06\n"
"3-22-1999 05:06\n"
"1999-3-22 05:06\n"
"99/03/22 05:06\n"
"1999.03.22\n"
"1999.03.22 05:06:07\n"
"1999.03.22 05:06\n"
"1999.03.22.\n"
"1999.03.22. 5:06:07\n"
"1999.03.22. 5:06\n"
"22.3.1999 05:06:07\n"
"22.3.1999 05:06\n"
"22-mar-1999\n"
"22/03/99 5.06\n"
"99-03-22 05:06\n"
"22-mar-1999 5.06.07\n"
"22 marzo 1999 5.06.07 CET\n"
"lunedì 22 marzo 1999 5.06.07 CET\n"
"05:06 22/03/99\n"
"05:06:07 22/03/1999\n"
"99/03/22\n"
"1999/03/22\n"
"99/03/22 5:06\n"
"03/22/99 5:06\n"
"3/22/99 5:06\n"
"03-22-99 5:06\n"
"3-22-99 5:06 AM\n"
"03-22-1999 5:06:07\n"
"3-22-1999 5:06:07\n"
"1999-03-22 5:06:07\n"
"99/03/22 5:06:07\n"
"3/22/99 5:06:07 AM\n"
"1999/03/22 5:06\n"
"22/03/1999 5:06\n"
"22/3/1999 5:06\n"
"03/22/1999 5:06\n"
"3/22/1999 5:06\n"
"03-22-99 5:06:07\n"
"3-22-99 5:06:07\n"
"03-22-1999 5:06\n"
"3-22-1999 5:06\n"
"1999-03-22 5:06\n"
"1999-3-22 5:06\n"
"99. 3. 22\n"
"1999. 3. 22\n"
"99.3.22\n"
"99.3.22 05.06\n"
"1999-03-22 05.06.07\n"
"99.22.3\n"
"1999.22.3\n"
"99.22.3 05:06\n"
"1999.22.3 05:06:07\n"
"22.3.99 05:06\n"
"22.3.1999 05:06:\n"
"22-3-99\n"
"22-3-99 5:06\n"
"22-03-1999\n"
"22-03-1999 5:06\n"
"22.03.99 5:06\n"
"22.03.1999 5:06:07\n"
"1999-03-22 5:06:07.PD\n"
"99-03-22 5.06.PD\n"
"1999-03-22 5.06.07.PD CET\n"
"22.3.99.\n"
"22.03.1999.\n"
"22.3.99. 05.06\n"
"22.03.1999. 05.06.07\n"
"22.03.1999. 05.06.07 CET\n"
"05:06:07 22-03-1999\n"
"05:06 22/03/1999\n"
"99-3-22\n"
"1999-3-22\n"
"1999年3月22日\n"
"1999年3月22日 星期一\n"
"99-3-22 上午5:06\n"
"1999-3-22 5:06:07\n"
"1999年3月22日 上午05时06分07秒\n"
"1999年3月22日 5時06分07秒 CET\n"
"1999年3月22日 星期一 上午05时06分07秒 CET\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")