use strict;
my $str = ';An orphan comment at the top of the file
#Another orphan comment
#Comment above a group
[Group1] #Group comment 1
Key1=Value1#Comment 1
Key2=Value 2
Key 3=Value 3
Key 4=Value4
Key5=Value \\#5;Comment 2
;Another comment above a group
[Group 2] ;Group comment 2
Key1 = Value1 #Comment 3
Key2 = Value 2
Key 3 = Value 3
Key 4 = Value4
Key 5 = Value\\;5 ;Comment 4
Key 6 = Value\\;6\\#1 ;Comment 5
Key 7 ;Comment 6
Key 8 = Value;7 \\\\;Comment 7
Key 8 =;Comment 7
Key 9 = Value\\\\;8 ;Comment 8
; with quotes
;An orphan comment at the top of the file
#Another orphan comment
#Comment above a group
[Group1] #Group comment 1
Key1="Value1"#Comment 1
Key2="Value 2"
Key 3="Value 3"
Key 4="Value4"
Key5="Value \\#5";Comment 2
;Another comment above a group
[Group 2] ;Group comment 2
Key1 = "Value1" #Comment 3
Key2 = "Value 2"
Key 3 =" Value 3"
Key 4 = "Value4"
Key 5 = "Value\\;5 ;Comment 4"
Key 6 = "Value\\;6\\#1 ";Comment 5
Key 7 ;Comment 6
Key 8 = "Value;7 \\";Comment 7
Key 8 ="";Comment 7
Key 9 = "Value\\\\";8 ;Comment 8
';
my $regex = qr/^[^\S\r\n]*
(?:
\s* (?<section>\[[^\]]*\]) [^\S\r\n]* (?<comment>(?:[#;].*)?)
| (?<comment>(?:[#;].*)?)
| (?:
(?<key>[^#;]+?)
\s* = [^\S\r\n]*
(?:
(?:
"(?<value_quote>.*)"
| (?<value>(?:[^#;\r\n\\\s]*[\s]??(?:\\.)*)*)
) [^\S\r\n]* (?<comment>(?:[#;].*)?)
)
)
| (?<error>.*)
)
$/ixmp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}