// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?ixm)^[^\S\r\n]*
(?:
\s* (?<section>\[[^\]]*\]) [^\S\r\n]* (?<comment>(?:[#;].*)?)
| (?<comment>(?:[#;].*)?)
| (?:
(?<key>[^#;]+?)
\s* = [^\S\r\n]*
(?:
(?:
"(?<value_quote>.*)"
| (?<value>(?:[^#;\r\n\\\s]*[\s]??(?:\\.)*)*)
) [^\S\r\n]* (?<comment>(?:[#;].*)?)
)
)
| (?<error>.*)
)
$"#).unwrap();
let string = ";An orphan comment at the top of the file
#Another orphan comment
#Comment above a group
[Group1] #Group comment 1
Key1=Value1#Comment 1
Key2=Value 2
Key 3=Value 3
Key 4=Value4
Key5=Value \\#5;Comment 2
;Another comment above a group
[Group 2] ;Group comment 2
Key1 = Value1 #Comment 3
Key2 = Value 2
Key 3 = Value 3
Key 4 = Value4
Key 5 = Value\\;5 ;Comment 4
Key 6 = Value\\;6\\#1 ;Comment 5
Key 7 ;Comment 6
Key 8 = Value;7 \\\\;Comment 7
Key 8 =;Comment 7
Key 9 = Value\\\\;8 ;Comment 8
; with quotes
;An orphan comment at the top of the file
#Another orphan comment
#Comment above a group
[Group1] #Group comment 1
Key1=\"Value1\"#Comment 1
Key2=\"Value 2\"
Key 3=\"Value 3\"
Key 4=\"Value4\"
Key5=\"Value \\#5\";Comment 2
;Another comment above a group
[Group 2] ;Group comment 2
Key1 = \"Value1\" #Comment 3
Key2 = \"Value 2\"
Key 3 =\" Value 3\"
Key 4 = \"Value4\"
Key 5 = \"Value\\;5 ;Comment 4\"
Key 6 = \"Value\\;6\\#1 \";Comment 5
Key 7 ;Comment 6
Key 8 = \"Value;7 \\\";Comment 7
Key 8 =\"\";Comment 7
Key 9 = \"Value\\\\\";8 ;Comment 8
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}