import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^##api(?<apicont>.+?)##.+?Функция\\s+(?<funcname>.+?)\\((?<funcparam>.+?)\\)\\s+\\{";
final String string = "##api\n"
+ "# @param лс - обязательный параметр. row_id ЛСа/дома/квартира\n"
+ "# @param наДату - обязательный параметр. Дата, на которую должена действовать УК\n"
+ "# @param результат - не обязательный параметр. Может быть только строкой (ЛСID, УКДатНач, УКДатКнц, ОрганизацияID, Название, Наименование, ДоговорID, Номер, ККС, ДоговорДатНач, ДоговорДатКнц, Объект_Организация, Объект_Договор), по умолчанию - пустая строка, определяет что вернуть в качестве результата, массив, конкретное поле или объект\n"
+ "# @param дом - не обязательный параметр. row_id дома, для проверки кеша\n"
+ "# @description возвращает массив с собранными данными об УК\n"
+ "##\n"
+ "Функция ПолучитьУКпоЛС(лс, наДату, ...) {\n\n"
+ "##api\n"
+ "# @param лс - обязательный параметр. row_id ЛСа/дома/квартира\n"
+ "# @param наДату - обязательный параметр. Дата, на которую должена действовать УК\n"
+ "# @param результат - не обязательный параметр. Может быть только строкой (ЛСID, УКДатНач, УКДатКнц, ОрганизацияID, Название, Наименование, ДоговорID, Номер, ККС, ДоговорДатНач, ДоговорДатКнц, Объект_Организация, Объект_Договор), по умолчанию - пустая строка, определяет что вернуть в качестве результата, массив, конкретное поле или объект\n"
+ "# @param дом - не обязательный параметр. row_id дома, для проверки кеша\n"
+ "# @description возвращает массив с собранными данными об УК\n"
+ "##\n"
+ "Функция ПолучитьУКпоЛС(лс, наДату, ...) {";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}