const regex = /^([cC]\/|[cC]alle|[aA]v\/|[aA]venida|[pP]laza\/|[pP]laza)\s([A-z ]{0,})\,\s\d+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([cC]\\\/|[cC]alle|[aA]v\\\/|[aA]venida|[pP]laza\\\/|[pP]laza)\\s([A-z ]{0,})\\,\\s\\d+$', 'gm')
const str = `calle prueba, 2
calle de la prueba, 5
Avenida de la prueba, 5
Plaza de la prueba, 5
Calle Higuereta, 4, 7º B
Calle Escritor Conde Zamora s/n
Avenida Ciudad de Aranjuez 18
Avenida Pintor Sorolla 125 4ºG
Polígono Industrial Aranguren 6
Calle Gremi Passamaners 24 2º
Avenida Manuel Rodriguez Ayuso, 170
Calle Illa de Buda 55
C/ Walia, 21
C/Alfonso Pesquera, 6`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}