package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\s*[a-zA-Z]+){1,3}`)
var str = ` " Test This stuff "
" Test this "
" Test "`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}