#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<1>frac{(?:\d+|(?<2>frac{(?:\d+|(?<3>frac{(?:\d+|(?<4>frac{\d+}{\d+}))}{(?:\d+|(?<4>frac{\d+}{\d+}))}))}{(?:\d+|(?<3>frac{(?:\d+|(?<4>frac{\d+}{\d+}))}{(?:\d+|(?<4>frac{\d+}{\d+}))}))}))}{(?:\d+|(?<2>frac{(?:\d+|(?<3>frac{(?:\d+|(?<4>frac{\d+}{\d+}))}{(?:\d+|(?<4>frac{\d+}{\d+}))}))}{(?:\d+|(?<3>frac{(?:\d+|(?<4>frac{\d+}{\d+}))}{(?:\d+|(?<4>frac{\d+}{\d+}))}))}))})"
Local $sString = "frac{frac{1}{2}}{frac{3}{frac{4}{frac{5}{6}}}}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")