using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<1>frac{(?:\d+|(?<2>frac{(?:\d+|(?<3>frac{(?:\d+|(?<4>frac{\d+}{\d+}))}{(?:\d+|(?<4>frac{\d+}{\d+}))}))}{(?:\d+|(?<3>frac{(?:\d+|(?<4>frac{\d+}{\d+}))}{(?:\d+|(?<4>frac{\d+}{\d+}))}))}))}{(?:\d+|(?<2>frac{(?:\d+|(?<3>frac{(?:\d+|(?<4>frac{\d+}{\d+}))}{(?:\d+|(?<4>frac{\d+}{\d+}))}))}{(?:\d+|(?<3>frac{(?:\d+|(?<4>frac{\d+}{\d+}))}{(?:\d+|(?<4>frac{\d+}{\d+}))}))}))})";
string input = @"frac{frac{1}{2}}{frac{3}{frac{4}{frac{5}{6}}}}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}