import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((.*)\\/(.*)\\/(.*) (.*):(.*):(.*)) (\\[(error)\\]) (\\[(.*)\\]) (([\\t\\n])?((?:[^\\t\\n]*[\\t\\n])+.*)|(.*))";
final String string = "2015/10/06 19:20:27 [error] [php] Trying to get property of non-object (/www/ussd/protected/components/Process.php:267)\n"
+ "Stack trace:\n"
+ "#0 /www/ussd/vendor/yiisoft/yii/framework/yiilite.php(3570): CInlineAction->runWithParams()\n"
+ "#1 /www/ussd/vendor/yiisoft/yii/framework/yiilite.php(3555): TestController->runAction()\n"
+ "#2 /www/ussd/vendor/yiisoft/yii/framework/yiilite.php(3545): TestController->runActionWithFilters()\n"
+ "#3 /www/ussd/vendor/yiisoft/yii/framework/yiilite.php(1746): TestController->run()\n"
+ "#4 /www/ussd/vendor/yiisoft/yii/framework/yiilite.php(1666): CWebApplication->runController()\n"
+ "#5 /www/ussd/vendor/yiisoft/yii/framework/yiilite.php(1191): CWebApplication->processRequest()\n"
+ "#6 /www/ussd/index.php(22): CWebApplication->run()\n"
+ "REQUEST_URI=/test/?dialog_id=32&ussd_text=*152%23&msisdn=995557231065&service_code=152";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}