using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"CLIENT\.\w+[\,\)]";
string input = @"CLIENT.TEST,Toto.test,Test.Test,CLIENT.NOM,
Zozo.zaza,CLIENT.Truc,Watch.Machin,";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}