re = /CLIENT\.\w+[\,\)]/m
str = 'CLIENT.TEST,Toto.test,Test.Test,CLIENT.NOM,
Zozo.zaza,CLIENT.Truc,Watch.Machin,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end