import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\d{3}[-]?\\d{3}[-]?\\d{4}|\\d{2}[-]?\\d{3}[-]?\\d{4}|\\d{1}[-]?\\d{3}[-]?\\d{6}|\\d{1}[-]?\\d{3}[-]?\\d{2}[-]?\\d{2}[-]?\\d{2}|\\*{1}?\\d{2,5}\\b";
final String string = "123-456-7899 123456789 03-123-4567 03-1234567 1-800-123456 \n"
+ "1800-123456\n"
+ "1-800-12-34-56 0544-123456 *12 *123 *1234 *12345";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}