re = /\b\d{3}[-]?\d{3}[-]?\d{4}|\d{2}[-]?\d{3}[-]?\d{4}|\d{1}[-]?\d{3}[-]?\d{6}|\d{1}[-]?\d{3}[-]?\d{2}[-]?\d{2}[-]?\d{2}|\*{1}?\d{2,5}\b/
str = '123-456-7899 123456789 03-123-4567 03-1234567 1-800-123456
1800-123456
1-800-12-34-56 0544-123456 *12 *123 *1234 *12345'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end