$re = '/^(?!.*?-\d+[xX]\d+)(.*)$/m';
$str = 'somefile.txt
another-67x22.img
-667x92.jpg
goodfile.pdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);