re = /^(?!.*?-\d+[xX]\d+)(.*)$/m
str = 'somefile.txt
another-67x22.img
-667x92.jpg
goodfile.pdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end