$re = '/(= WINDOW[ ]*\n)(.*?)(SPACER-TYPE)/s';
$str = '"Window 491" = WINDOW
GLASS-TYPE = "Baseline Window"
X = 8
SPACER-TYPE = ALUMINUM
PIPI = CACA
..
"Window 491" = WINDOW
GLASS-TYPE = "Baseline Window"
X = 8
SPACER-TYPE = ALUMINUM
PIPI = CACA
..';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);