re = /(= WINDOW[ ]*\n)(.*?)(SPACER-TYPE)/
str = '"Window 491" = WINDOW
GLASS-TYPE = "Baseline Window"
X = 8
SPACER-TYPE = ALUMINUM
PIPI = CACA
..
"Window 491" = WINDOW
GLASS-TYPE = "Baseline Window"
X = 8
SPACER-TYPE = ALUMINUM
PIPI = CACA
..'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end