# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<(\w+)\s*.*?>\s*?<\/\1>//g;t' <<< "<p></p><div> to make links</div><b> </b>
<a href=\"http://foo.com\"></a><p> for linebreak add 2 spaces at end
</p><strong></strong><i></i>"