use strict;
my $str = '<p></p><div> to make links</div><b> </b>
<a href="http://foo.com"></a><p> for linebreak add 2 spaces at end
</p><strong></strong><i></i>';
my $regex = qr@<(\w+)\s*.*?>\s*?</\1>@p;
my $subst = '';
my $result = $str =~ s@$regex@$subst@rg;
print "The result of the substitution is' $result\n";