#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(0[1-9]|1[0-2])\/?([0-9]{4}|[0-9]{2})$"
Local $sString = "02/13" & @CRLF & _
"0213" & @CRLF & _
"022013" & @CRLF & _
"02/2013" & @CRLF & _
"02/203" & @CRLF & _
"02/2" & @CRLF & _
"02/20322"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")