package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(0[1-9]|1[0-2])\/?([0-9]{4}|[0-9]{2})$`)
var str = `02/13
0213
022013
02/2013
02/203
02/2
02/20322`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}