import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(@(?<scope>[a-z0-9][a-z0-9-]*))\\/(?<name>([a-z0-9][a-z0-9-]*)(\\/([a-z0-9][a-z0-9-]*))*)$";
final String string = "\n\n\n"
+ "@collboard/foo\n"
+ "@collboard/bar\n"
+ "@collboard/foo/bar\n"
+ "@collboard/foo/bar/foobar\n"
+ "@collboard/1/2/3\n"
+ "@collboard/foo-1/bar-2/foobar-3\n"
+ "@collboard-bar/foo-1/bar-2/foobar-3\n\n\n\n"
+ "collboard\n"
+ "@collboard\n"
+ "/missing-scope\n"
+ "/@collboard\n"
+ "@collboard/\n"
+ "@-collboard/foo\n"
+ "@collboard/-foo\n"
+ "@collboard/foo/\n"
+ "@collboard//foo\n"
+ "@collboard/Foo\n"
+ "@collboard/foo*\n"
+ "@collboard/foo~\n"
+ "@collboard/foo+\n"
+ "@collboard/foo_bar";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}