const regex = /^(@(?<scope>[a-z0-9][a-z0-9-]*))\/(?<name>([a-z0-9][a-z0-9-]*)(\/([a-z0-9][a-z0-9-]*))*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(@(?<scope>[a-z0-9][a-z0-9-]*))\\\/(?<name>([a-z0-9][a-z0-9-]*)(\\\/([a-z0-9][a-z0-9-]*))*)$', 'gm')
const str = `
@collboard/foo
@collboard/bar
@collboard/foo/bar
@collboard/foo/bar/foobar
@collboard/1/2/3
@collboard/foo-1/bar-2/foobar-3
@collboard-bar/foo-1/bar-2/foobar-3
collboard
@collboard
/missing-scope
/@collboard
@collboard/
@-collboard/foo
@collboard/-foo
@collboard/foo/
@collboard//foo
@collboard/Foo
@collboard/foo*
@collboard/foo~
@collboard/foo+
@collboard/foo_bar`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}