package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)('[^'\\]*(?:\\.[^'\\]*)*')|\s*,\s*`)
var str = `'Hello world',dude, 'Somethi\'ngs, never, turn and go, bye`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}