import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "```(.*?)```";
final String string = "head of file\n\n"
+ "```\n"
+ "code\n"
+ "```\n\n"
+ "docs text\n\n"
+ "```\n"
+ "code2\n"
+ "```\n\n"
+ "end of file";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}